load_workbook error for 1707 version excel & pip install / upgrade error openpyxl

Hola chicos, estoy trabajando en python (x, y) 2.7.10.0 y el package openpyxl 2.2.4 se instaló cuando instalé python (x, y). Ahora quiero que se actualice a la versión 2.4.8. Porque cuando mi Excel se actualizó a la versión 1707, encontré un error en mi script. Parece que la function load_workbook no funciona bien en mi caso:

wb_read = load_workbook(dir_path_full, data_only = True) 

Información de error:

 runfile('C:/Users/test/Desktop/Version test/test/test.py', wdir='C:/Users/test/Desktop/Version test/test') Traceback (most recent call last): File "<ipython-input-1-a825cbef2110>", line 1, in <module> runfile('C:/Users/test/Desktop/Version test/test/test.py', wdir='C:/Users/test/Desktop/Version test/test') File "C:\Python27\lib\site-packages\spyderlib\widgets\externalshell\sitecustomize.py", line 685, in runfile execfile(filename, namespace) File "C:\Python27\lib\site-packages\spyderlib\widgets\externalshell\sitecustomize.py", line 71, in execfile exec(compile(scripttext, filename, 'exec'), glob, loc) File "C:/Users/test/Desktop/Version test/test/test.py", line 32, in <module> wb_read = load_workbook(dir_path_full, data_only = True) File "C:\Python27\lib\site-packages\openpyxl\reader\excel.py", line 149, in load_workbook _load_workbook(wb, archive, filename, read_only, keep_vba) File "C:\Python27\lib\site-packages\openpyxl\reader\excel.py", line 236, in _load_workbook color_index=wb._colors) File "C:\Python27\lib\site-packages\openpyxl\reader\worksheet.py", line 327, in read_worksheet fast_parse(ws, xml_source, shanetworking_strings, style_table, color_index) File "C:\Python27\lib\site-packages\openpyxl\reader\worksheet.py", line 315, in fast_parse parser.parse() File "C:\Python27\lib\site-packages\openpyxl\reader\worksheet.py", line 94, in parse dispatcher[tag_name](element) File "C:\Python27\lib\site-packages\openpyxl\reader\worksheet.py", line 291, in parse_data_validation dv = parser(tag) File "C:\Python27\lib\site-packages\openpyxl\worksheet\datavalidation.py", line 225, in parser dv = DataValidation(**element.attrib) TypeError: __init__() got an unexpected keyword argument '{http://schemas.microsoft.com/office/spreadsheetml/2014/revision}uid' 

De todos modos, traté de usar pip para tener mi openpyxl actualizado a 2.4.8:

 pip install --upgrade openpyxl 

Y cmd dice:

 Requirement already up-to-date: openpyxl in c:\python27\lib\site-packages Requirement already up-to-date: jdcal in c:\python27\lib\site-packages (from openpyxl) Requirement already up-to-date: pillow in c:\python27\lib\site-packages (from openpyxl) 

Luego traté de download el package 2.4.8 al principio e instalarlo localmente:

  pip install ./downloads/openpyxl-2.4.8.tar.gz 

Esta vez el cmd dice:

 Processing c:\users\test\downloads\openpyxl-2.4.8.tar.gz Requirement already satisfied (use --upgrade to upgrade): jdcal in c:\python27\lib\site-packages (from openpyxl==2.4.8) Collecting et-xmlfile (from openpyxl==2.4.8) Could not find a version that satisfies the requirement et-xmlfile (from openpyxl==2.4.8) (from versions: ) No matching distribution found for et-xmlfile (from openpyxl==2.4.8) 

¿Han conocido el mismo problema antes o tienen alguna idea sobre mi problema? ¡Muchas gracias por adelantado!

Aclamaciones.